论坛cms flarum轻社区beta12中文版安装包

在安装Flarum之前,重要的是要检查您的服务器是否符合要求。要运行Flarum,您将需要:

Apache(启用mod_rewrite)或Nginx
PHP 7.1+具有以下扩展名:curl,dom,gd,json,mbstring,openssl,pdo_mysql,tokenizer,zip
MySQL 5.6以上或MariaDB 10.0.5以上

论坛cms flarum轻社区中文版安装包

更新内容

  • 我们将本发行版的重点放在更改上,以使Flarum更好地体验,无论是对于社区中的优秀开发人员还是Flarum网站的管理员。
  • Flarum现在完全支持PHP7.4啦!
  • 固定链接地址(slugs)现在支持基本的UTF-8文字音译了,再也不怕帖子的URL空荡荡的。
  • 邮件设置现在支持mailgun的区域设置,并将检查设置的完整性。
  • 现在可以通过向用户组授予权限来避免限制(默认情况下,管理员现在不受任何限制)。
  • IE11/Edge浏览器中上传头像的功能又回来了。
  • 用户现在可以标记(举报)自己的帖子,我们也对标记(举报)功能做了其他改进。
  • 自定义路径功能。在新装站点时,您现在可以只通过设置site.php文件就能让论坛运行在站点的子目录下。
  • 当任何一种语言(如英语)的翻译键缺少翻译时,将自动调用默认语言的翻译,您不会再看到这样的字符串了:core.flarum.this.looks.weird。
  • TextFormatter已更新至 2.3.6 版本,新增Markdown的扰流器功能。别担心,我们仍支持你的BBBBCode扩展。
  • 已为中间件和错误处理添加了Extenders,扩展程序的开发更容易了。
  • Zend库已被弃用,我们添加了它的代替品:Laminas。

内置插件扩展

  • 实时聊天开发版 [Realtime Chatdev-master]
  • 搜索引擎优化 [SEO]
  • 文件上传 [Upload]
  • 中文语言包
  • 支持中文名注册 [username chinese support]
  • 彩色用户名 [Coloured Usernames]
  • sitemap地图 [Flagrow Sitemap]
  • 用户等级 [ReFlar Level Ranks]
  • 回复可见 [Reply 2 See]
  • 夜间模式 [FoF Night Mode]

论坛cms flarum轻社区中文版安装包

注意事项

网站目录设置如下
论坛cms flarum轻社区中文版安装包
伪静态设置

安装包里配置了Nginx伪静态,引用即可。

宝塔里伪静态设置 include /www/wwwroot/xxxxxx.com/flarum/.nginx.conf;

在安装过程中,Flarum会要求您将某些文件夹设置为权限级别755。PHP安装fileinfo扩展。

发表评论