Composer更新慢的终极解决方案:无法下载“ https://packagist.laravel-china.org/packages.json”文件

Composer更新慢的终极解决方案:无法下载“ https://packagist.laravel-china.org/packages.json”文件
使用composer安装错误提示:

无法下载“ https://packagist.laravel-china.org/packages.json”文件:对等证书CN = *.phphub.org’ did not match expected CN=packagist.laravel-china.org’

无法启用加密

无法打开流:操作失败

https://packagist.laravel-china.org无法完全加载,软件包信息是从本地缓存加载的,可能已过期Composer更新慢的终极解决方案:无法下载“ https://packagist.laravel-china.org/packages.json”文件

解决方法

阿里云作曲家

Packagist官方实时同步,推荐使用最新的Composer版本。可使用composer self-update命令更新

总体配置(推荐

所有项目都会使用该特定地址:

composer config -g repo.packagist composer https://mirrors.aliyun.com/composer/

取消配置:

composer config -g --unset repos.packagist

项目配置

仅修改当前工程配置,仅当前工程可使用该补充地址:

composer config repo.packagist composer https://mirrors.aliyun.com/composer/

取消配置:

composer config --unset repos.packagist

调试

composer命令增加-vvv可输出详细的信息,命令如下:composer -vvv require alibabacloud/sdk

发表评论